简体中文
会员名称: 登入密码: [Register] 注册 忘记密码 启用我的帐号
 
[下载]JForum.T (JForum 2.1.8 + TryDone 模板) 最近更新(2008-03-12)  XML
论坛首页 »开源项目» JForum论坛
发表人 内容
Admin

[Avatar]
注册时间: 2006-11-18 20:56:41
文章: 141
来自: 福州
离线

JForum 2.1.8 + TryDone 模板,这里就简称JForum.T吧
TryDone模板简介


下载地址:
地址1: http://code.google.com/p/trydone/downloads/list
源代码下载: http://code.google.com/p/trydone/source/checkout

具体更新日志查看:
http://www.trydone.com/svn/revisionList.jsp?url=trunk

更新:
20080318

这篇文章被编辑了 26 次. 最近一次更新是在 2009-05-08 09:42:25


相互帮助,共同进步.
[Email] [WWW] [MSN]
chenhy


注册时间: 2007-06-01 10:01:52
文章: 1
离线

你们好!很感谢你们的工作!
我下载了新的版本,不是完整版,只是war文件,我的mysql是5.0版本的,默认字符集为utf8,怎么运行安装后首页上有乱码???
希望得到解决,再次感谢!
pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18

是有一个乱码,你得改改/templates/trydone/header.htm的文件编码.因为里面有几个是中文的,
你试一下把文件编码改为utf-8/unicode等试试

这篇文章被编辑了 1 次. 最近一次更新是在 2007-06-01 13:07:10


享我所想,乐你所乐
[MSN] Tencent QQ:44020567
xzc


注册时间: 2007-03-23 12:52:37
文章: 106
离线

标题应该是“JForum 2.1.8 + TryDone 模板” 了?2.1.8了?
pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18

2007-07-17 解决在linux下中文问题(在Ubuntu 7.04测试通过)
安装完后默认的版块与内容还是乱码,不管它, 把它删除新建你想的的版块就行了
如果不想看到这个乱码安装前可以把 /WEB-INF/config/database/mysql/mysql_data_dump_zh_CN.sql删除
原因是在linux下默认读取文件的编码不认中文,可以修改程序读取文件的编码来实现,这里不做修改

这篇文章被编辑了 1 次. 最近一次更新是在 2007-07-17 17:28:55


享我所想,乐你所乐
[MSN] Tencent QQ:44020567
ludeng0874


注册时间: 2007-07-25 14:38:15
文章: 8
离线

装了2070726的最新版本,注册和热门主题都没问题了,但是后台的系统管理>论坛管理中“版面分类”和“版面管理”中新增记录怎么不显示的,这样就没办法删除和修改了。
pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18

ludeng0874 wrote:装了2070726的最新版本,注册和热门主题都没问题了,但是后台的系统管理>论坛管理中“版面分类”和“版面管理”中新增记录怎么不显示的,这样就没办法删除和修改了。

那是权限设置问题,你可以在本站查询一下 "权限设置" 相对内容看看

享我所想,乐你所乐
[MSN] Tencent QQ:44020567
jdonee


注册时间: 2007-06-06 10:37:39
文章: 7
离线

楼主,新版本支持本地上传吗
pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18

附件支持,直接图片上传不支持.

享我所想,乐你所乐
[MSN] Tencent QQ:44020567
liufeng


注册时间: 2007-08-03 00:23:44
文章: 5
离线

站长你好,我的测试数据库是:mysql5.0.18
JForum 2.1.7 + TryDone 模板
可是安装成功后,出现错误:
Expression templateName is undefined on line 5, column 14 in exception.html. The problematic instruction: ---------- ==> ${templateName} [on line 5, column 12 in exception.html] in include "${templateName}/message.htm" [on line 5, column 1 in exception.html] ---------- Java backtrace for programmers: ---------- freemarker.core.InvalidReferenceException: Expression templateName is undefined on line 5, column 14 in exception.html. at freemarker.core.TemplateObject.assertNonNull(TemplateObject.java:124) at freemarker.core.Expression.getStringValue(Expression.java:11 at freemarker.core.Expression.getStringValue(Expression.java:93) at freemarker.core.DollarVariable.accept(DollarVariable.java:76) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.MixedContent.accept(MixedContent.java:92) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.Environment.renderElementToString(Environment.java:1461) at freemarker.core.StringLiteral.getStringValue(StringLiteral.java:95) at freemarker.core.Include.accept(Include.java:110) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.MixedContent.accept(MixedContent.java:92) at freemarker.core.Environment.visit(Environment.java:196) at freemarker.core.Environment.process(Environment.java:176) at freemarker.template.Template.process(Template.java:232) at net.jforum.exceptions.ExceptionWriter.handleExceptionData(ExceptionWriter.java:110) at net.jforum.JForum.handleException(JForum.java:284) at net.jforum.JForum.service(JForum.java:205) at javax.servlet.http.HttpServlet.service(HttpServlet.java:802) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:237) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157) at net.jforum.util.legacy.clickstream.ClickstreamFilter.doFilter(ClickstreamFilter.java:59) at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:186) at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:157) at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214) at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) at org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:19 at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152) at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137) at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:11 at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:102) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) at org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104) at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520) at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:929) at org.apache.coyote.tomcat5.CoyoteAdapter.service(CoyoteAdapter.java:160) at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:300) at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:374) at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:743) at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:675) at org.apache.jk.common.SocketConnection.runIt(ChannelSocket.java:866) at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:683) at java.lang.Thread.run(Thread.java:595)


我将数据库换成 mysql4.0.14 ,后可以成功安装,
1、可是在浏览帖子的时候出现如下错误:
For detailed error information, please see the HTML source code, and contact the forum Administrator.

You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'SELECT DISTINCT user_id FROM jforum_posts WHERE topic_id = 1)'

Query being executed when exception was thrown:

SELECT user_id, username, user_karma, user_avatar, user_allowavatar, user_regdate, user_posts, user_icq, user_from, user_email, rank_id, user_sig, user_attachsig, user_viewemail, user_msnm, user_yim, user_website, user_sig, user_aim FROM jforum_users WHERE user_id IN (SELECT DISTINCT user_id FROM jforum_posts WHERE topic_id = 1)

��̳��ҳ
2、在后台建立板块的时候建立8个就不能建立了,加上去提交后没反应。
由于服务器的数据库不能升级,只能是mysql5.0.18 和mysql4.0.14 ,恳请大家帮忙,,小弟万分感谢
pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18

templateName is undefined on...你看看你的模板名称有没改正确.

/WEB-INF/config/jforum-custom.conf
加入一行
template.dir=trydone
如果要用默认的模板,把这一行删除

享我所想,乐你所乐
[MSN] Tencent QQ:44020567
liufeng


注册时间: 2007-08-03 00:23:44
文章: 5
离线

#Installation specific configuration options
#Fri Aug 03 09:28:36 CST 2007
i18n.board.default=zh_CN
forum.link=http\://127.0.0.1\:8080/bbs/
database.support.autokeys=true
database.driver.name=mysql
database.connection.pool.timeout=5000
database.connection.dbname=mydatabase
installed=true
database.support.subqueries=true
dao.driver=net.jforum.dao.mysql.MysqlDataAccessDriver
homepage.link=http\://127.0.0.1\:8080
mysql.unicode=
database.connection.pool.min=5
database.connection.password=123456
database.connection.pool.max=10
user.hash.sequence=a43d17ab1b8c35ce60d2d867868b28b4
database.connection.username=netchd
dbencoding=utf-8
database.connection.port=3307
dbunicode=true
database.connection.implementation=net.jforum.PooledConnection
database.connection.host=localhost
database.connection.driver=com.mysql.jdbc.Driver
database.connection.string=jdbc\:mysql\://${database.connection.host}\
:${database.connection.port}/${database.connection.dbname}?
user\=${database.connection.username}&password\=${database.connection.password}
&autoReconnect\=true${mysql.unicode}${mysql.encoding}&useNewIO\=false
&zeroDateTimeBehavior\=convertToNull&useServerPrepStmts\=false
&dumpQueriesOnException\=true&jdbcCompliantTruncation\=false&characterEncoding\=${dbencoding}
mysql.encoding=


我把这行 template.dir=trydone ,加入后还是提示一样得找不到

这篇文章被编辑了 2 次. 最近一次更新是在 2007-08-03 14:26:23

pinke

[Avatar]

注册时间: 2006-11-18 22:27:35
文章: 919
离线
性别: 男
出生:1982-06-18


database.connection.port=3307
你改过mysql的数据库端口吗?默认是3306
如果不是模板问题,一般都跟数据库有关系,看看数据库是否连接正常

享我所想,乐你所乐
[MSN] Tencent QQ:44020567
liufeng


注册时间: 2007-08-03 00:23:44
文章: 5
离线

我用的是3307,应该是数据库的问题。因为我现在用的服务器是别人的。在本机上是没问题了。
liufeng


注册时间: 2007-08-03 00:23:44
文章: 5
离线

我再找找原因,谢谢你的回复。。非常感谢
 
论坛首页 »开源项目» JForum论坛
前往:   
Powered by JForum 2.1.8 © JForum Team Template: Trydone